
  

Know the ELEMENTS of Milestones Professional 

Getting Started Milestones Professional 

If you know the names of the elements of the Milestones Professional window then you can access information about 

these elements using the Milestones Professional Help. 

To maneuver around the Milestones Professional window use: the Toolbox’s Arrow tool to select ele-

ments; the Plus tool for adding symbols, horizontal bars, vertical links; the T  tool for adding text . 

http://www.kidasasoftware.com/support/help/pro2019/index.htm#t=Guided_Help_-_Welcome_to_Milestones_Professional.htm
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Set up the TOOLBOX 

Double click a horizontal bar to get the Bar Options dialog box to 

change the characteristics of a horizontal Bar: Shape, Line Pattern, 

Before Status Color and Fill Pattern, After Status Color and Fill 

Pattern,  Line Pattern,  Arrowhead size of Arrow Bars, Shadow. 

Double click a vertical link 

to get the Vertical Link 

Options dialog box to 

change the characteristics 

of a vertical link: Shape, 

Line Pattern, Color, Arrow-

head Type and Size, Show 

on Top , Rounded Corners, 

Off Page Connections Op-

tions. 

Horizontal bars and vertical links 

always originate out of a symbol. 

When an actual symbol shape is 

not visible null symbol style #28 

or #33 is being used. 

Set up the toolbox to have the style of symbols, symbol-horizontal bar-symbol 

combinations and/or vertical links to add to your schedule. 

Double click any symbol, horizontal bar or vertical link in the toolbox to open 

its Options dialog to changes its characteristics . 

Double click a symbol to get the Symbol Options dialog box.  Select a tab to change the 

characteristics of a symbol: Shape, Type, Before Status Color, After Status Color, After 

Status Symbol, Shadow, Size, Text Placement, Date Placement , Date Format, Vertical 

Position on a Task Row, Text Background Color, Default Text, ValueSet Value. 
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Set your schedule’s LAYOUT  

Choose the Layout tab:  set the Printer Orientation selecting to have your schedule Landscape or Portrait; change the Chart Size; 

change the Margins, Check on Ignore Automatic Top Margin to remove default space at the top of the schedule; change the Rows 

Per Page (increase the rows per page if you want some rows bigger than others); Enter Legend Height (an entry of 0 will delete the 

legend). 

Select Overall Column Layout to activate the toolbar for all columns. To: Add -  enter a value (Choose the Insert tab to insert spe-

cific column types), Remove -  select the red X under the columns value, Resize  - change the current value, Hide - select the blue 

box with column number, it will change to gray keeping the column value (size) however hiding the column. 
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Set your schedule’s DATE RANGE 

The date range is the time span which is displayed in the schedule area. The date range can be as small as one minute (in which 
case the start and end dates are the same), or it can span several years, decades, or centuries. 

Set your schedule’s DATE HEADINGS 

Up  to 4 date headings can be shown on a schedule.  Headings can be placed above and/or below the schedule area.  Date head-
ings can be attached to a task row.  For each level, choose one of the 30+ built in headings or create a custom heading.  It's even 
possible to set up logarithmic headings to enlarge one or more time period. 

Choose the Dates tab - In the Start and End Dates section - Change the Dis-

played Start Date and Displayed End Date.  Manually enter the date, then 

select the apply button or use the calendar icons to select the dates.  

Review the options in the More Date Settings section to have Date Overrides 

on Pages,  Set Fiscal Year Settings, Show and Shade Holidays and Weekends, 

Allow Hourly, Minute, Work Shift Display. 

Choose the Dates tab - In the Date Headings section - Choose Date Headings Full Dialog  OR  click 

on any date heading to activate the Selection tab containing date headings options: Font Type, 

Style, Color, Size; Start # (some headings); Frequency; Background Color/Effects; Add Prefix and /or 

Suffix (some headings); Show Headings on Top and/or Bottom of the schedule. 

Choose Edit Custom Headings to create your own headings. 

Logarithmic Headings Choose the View  tab - In the Viewing Options  section - Choose the down 

arrow under Chart Type  - Choose Gantt- Logarithmic SetUp. 

After set up is complete choose Gantt– Logarithmic View .  You can switch back and forth between 

views. 

http://www.kidasasoftware.com/support/help/pro2019/The_Milestones_window.htm
http://www.kidasasoftware.com/support/help/pro2019/Create_or_edit_a_custom_heading.htm
http://www.kidasasoftware.com/support/help/pro2019/Logarithmic_date_headings.htm
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Add a SYMBOL to your schedule 

Add a SYMBOL-HORIZONTAL BAR-SYMBOL combination to your schedule 

1. Click the Big Plus tool. 

2. In the toolbox click the Symbol to be added. 

3. Move the cursor to the schedule area. 

4. Left Click and hold the mouse button, Drag to the 
symbol’s date. 

5. Let go of the mouse. 

1. Click the Big Plus tool. 

2. Click the Small Plus next to the symbol-horizontal bar
-symbol combination to be added. 

3. Move the cursor to the schedule area. 

4. Left Click (the first symbols will display) and hold the 
mouse button, Drag to the second symbol’s date. 

5. Let go of the mouse. 

Symbols and/or symbol-horizontal bar-

symbol combinations can be added to a 

schedule using  Start Date, End Date, 

Baseline Start Date and Baseline End 

Date columns.   

Select the SmartColumn Heading  to set 

up the  symbols and horizontal bars to be 

used. Click Here for more information. 

For a symbol bar-horizontal-bar symbol 

combination to look like just a bar on 

the schedule .  Set up a combination in 

the toolbox with symbol style # 28 or 

#33 (null  symbols) on the left and right 

of the horizontal bar of your choice. 

http://www.kidasasoftware.com/support/help/pro2019/index.htm#t=Start_date_SmartColumn.htm
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 Add a HORIZONTAL BAR between two existing Symbols on your schedule 

1. Click the Big Plus tool. 

2. On the schedule click the Start Symbol for 
the horizontal connection. 

3. In the toolbox click the Horizonal Bar to be 
used. 

4. On the schedule click the Symbol to Com-
plete the horizontal connection. 

Horizontal Bars are connections (dependencies) between symbols on the same task row. 

Because symbols can be at different levels on a single task row 

there are several Horizontal Bar types (43, 44, 45, 46) in the toolbox 

that allow a vertical connection look within a task row. 

5. The Result. 

Add a HORIZONTAL BAR AND SYMBOL to a Symbol on your schedule 

1. Click the Big Plus tool. 

2. Click the Horizontal Bar to be added. 

3. Click the Symbol to be added.                            

4. On the schedule, 
left Click the Symbol 
that the horizontal 
bar and symbol will 
be added to. Contin-
ue to hold the 
mouse button, and 
Drag to the sym-
bol’s date. 
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Add a VERTICAL LINK to your schedule 

1. Click the Big Plus tool. 

2. On the schedule click the Start Symbol for the ver-
tical connection. 

Vertical links  can also be added to a schedule using  the toolbar and the Insert tab.  Click Here  for more information. 

3. In the toolbox click the Vertical Link to be used. 

4. On the schedule click the Symbol to Complete the 
vertical connection. 

Vertical links are connections (dependencies) between symbols on different task rows. 

http://www.kidasasoftware.com/support/help/pro2019/index.htm%23t=Add_vertical_links_dependencies.htm
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 Add COLUMN TEXT to your schedule 

Add FREEFORM TEXT to your schedule, then Format it 

1. Click the Text  tool. 

2. On the schedule Click in a Columns Cell the cursor will flash. 

3. Begin Typing. 

FreeForm text can be added anywhere on the schedule. It is static thus it will not move when the schedule is adjusted.   

1. Click the Text  tool. 

2. Click anywhere on the schedule, the cursor 
will flash. 

3. Begin Typing. 

Column text characteristics an be globally set on the Format tab in the Default Text sec-

tion or individually by selecting the column. The toolbar is now active for the column, 

make change to the characteristic of column text in the toolbar. 

1. Click the Arrow tool. 

2. Click the freeform text block.  The toolbar is 
now active for the freeform text, make change 
to the characteristic of freeform text in the 
toolbar.  

Add  the schedule date, computer 

time and/or date, file name, page 

number anywhere on the schedule 

using Substitutable FreeForm text . 

Click Here for  more information. 

Globally set freeform text characteristics on the 

Format tab in the Default Text section. 

http://www.kidasasoftware.com/support/help/pro2019/index.htm#t=Substitutable_freeform_text.htm&rhsearch=freeform%20text&rhhlterm=freeform%20text&rhsyns=%20
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 Add SYMBOL TEXT to your schedule 

Each symbol can have up to three lines of text. 

1. Click the Arrow  tool. 

2. Click the Symbol to have text. The toolbar is now active for that symbol. 

3. Move the cursor to the Text section next to Line 1: click. 

4. Start Typing. 

5. Important, select the Apply Text Changes button to have the text display on the symbol. 

6. Choose the Text Override button for a line to change that line’s text color and/or attributes. 

In the active toolbar for the symbol, change the Symbol Text’s Color, Attributes and/or Size for the selected symbol. These changes 

also effect the symbol date. Note,  these options are overridden by the Text Overrides options. 

Also change the Text Placement around the selected symbol. If the symbol is the start of the symbol-horizontal bar-symbol combi-

nation and text is to be centered on the bar check on Center Text on Bar. 

Also change the Date Placement around the selected symbol. Add a Date Prefix and/or Suffix.  Set a Custom Date format. 

Globally set symbol text characteristics on the Format tab in the Default Text section. 
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Add SYMBOL NOTES to your schedule 

1. Click the Arrow  tool. 

2. Click the Symbol to have a note. The 
toolbar is now active for that symbol. 

3. At the bottom of the toolbar select the 
Notes tab. 

4. Move the cursor to the white block. 

5. Start Typing. 

6. Important, select the Apply Text Changes button to have the text display on the symbol. 

In the active toolbar for the symbol, change the Note’s Color, Attributes and/or Size for the selected symbol.  

Also change the Note’s Background coloring, effects, frame and connector type.  

Use the Directional Arrows to move the note anywhere on the schedule. Also, the toolbox arrow tool can be used to move the 

Note. 

Highlight and/or Number symbol with a note. Show or Hide the note. 

Each line of a note can appear different by using codes. Click Here for more information. 

Globally set symbol note characteristics on the Format tab in the Default Text section. 

http://www.kidasasoftware.com/support/help/pro2019/index.htm#t=format_symbol_notes.htm
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Add HORIZONTAL GRIDLINES AND SHADING  to your schedule 

1. To globally set Horizontal Gridlines and Shading choose 
the Format tab. 

2. In the Gridlines section choose Horizontal Gridlines and 
Shading. 

3. Choose the Gridlines tab. 

4. Check on Show Gridlines for the schedule’s Left Columns, 
Graph Schedule Area and/or Right Columns. 

5. Select the Line Type for each section. 

6. Select the Line Color for each section. 

7. Select the Shading tab. 

8.  Because each section of the schedule is to have the same 
shading options check on Apply New Selection to all Three 
Sections. 

9. Under Left Columns check on Shade the Task Rows. 

10.Select a Shade Color  

11.Optionally choose Effects Target Color and Special Effects 
and/or Alternating Pattern.  

Note: Once the Left Columns options are selected  the Graph/
Schedule Area and Right Columns will also have the same 
selections. 

To individually set a single task row’s or multiple task 

rows’ Horizontal Gridlines and Shading,  Click Here for 

more information. 

Horizontal Gridlines and Shading can be set globally or individually (for a single task row or multiple task rows). 

http://www.kidasasoftware.com/support/help/pro2019/index.htm#t=Customize_horizontal_gridlines_for_selected_task_rows.htm
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Add VERTICAL GRIDLINES  to your schedule 

1. Select the Format tab. 

2. Select Vertical Gridlines. 

3. Select Yearly to Weekly, Daily to Minute or Custom tab. 

4. Check on the time increment for the vertical gridlines to 
display. 

5. Select the Line Type. 

6. Select the Line Color. 

7. Optionally ,select Frequency or Extend Vertical Gridline into 
DataGraph Area. 

The blue vertical shading in the picture above, is a cur-

tain.  Saturday and Sundays can also be shaded.  Find 

these options on the Format tab in the Vertical Shad-

ing section, choose Curtains (Shade by Date Range) 

and/or Weekend and Holiday Shading. 

Curtains can also be displayed on task row(s).  

Click Here for more information. 

http://www.kidasasoftware.com/support/help/pro2019/index.htm#t=Curtains.htm
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Quick ADDS  to your schedule 

Schedule Title:  Insert tab   Title section select   Inset/Edit Chart Title 

Current Date:  Dates tab   Current Date section   check on Display Date (will display in  
upper right corner of schedule). Once the date is on the schedule, select it to 
activate the toolbar to changes the dates characteristics.   

Current Date Line:  Dates tab   Current Date section  check on Display Date Line  

Different Date Range on a Page:  Dates tab   More Date Settings section  choose Page by Page Date Range Overrides         
enter a Starting Date and Ending Date next to Current Page Override  

Page:  Insert tab   Page section    select Insert a New Page Before the Current Page or Insert a New Page After the Last Page 

Page Number:  View tab  Optional Item section  check on Page Number (will display 
in upper left corner of schedule). Once the Page Number is on the sched-
ule, select it to activate the toolbar to changes the Page Numbers charac-
teristics.   

Picture:  Insert tab   Picture,Legend section  select Picture from File 

Legend Entry:  Insert tab   Picture,Legend section  select Legend Entry 

Task Row:  In the column area, select the task row below the task row to be inserted   select the Insert tab   in the  
Row,Columns section   select New Task Row 

Password: File tab   Files and Templated Open and Save Options section   select Password 

Page Break:  Insert tab   Page Breaks section 

Bookmark:  View tab  Page Navigation section   select Bookmark 

Baseline:  Insert tab   Baseline, Datagraph, ValueSet section   select Insert or 
Remove a Baseline 

To place the Date anywhere on the 

schedule, choose the T (Text) Tool 

in the toolbox and type &date. 

To place the page number anywhere on 

the schedule, choose the T (Text) Tool in 

the toolbox and type &curpage . 

To set up the symbols and horizontal bar to 

be used for Baseline choose the Layout tab in 

the Other section choose Baseline Settings. 


