Trouble Refreshing or Importing from Project

Question:     

The connection to Project seems to be broken.  I am unable to refresh or import any Project schedules into Milestones.

Question:     

I receive a message "Can't connect to Project"

Question:     

I am receiving an unhandled exception when refreshing from Project.

Question:     

I am trying to refresh a schedule but am unable to pick a Microsoft Project file.

 

Answer:

Milestones Professional creates a Microsoft Project object and using COM to communicate with Project while retrieving schedule information to build or update the Milestones schedule.  If Project isn't registered/installed correctly Milestones might have trouble.  

 

Things to try:

  1. Check to see if Microsoft Project is waiting for input.
    1. After you have chosen to refresh or import, Milestones will open the selected Microsoft Project file.
    2. You should immediately receive a dialog box from Milestones. 
    3. If nothing happens, please locate the Microsoft Project icon in the toolbar and click it to toggle over to Project to see if Project is waiting for you to respond to a dialog box.
  2. Send us the System Info.  This can tell us if Microsoft Project is installed correctly.
    1. On the Help tab, choose  
    2. Press the  button.
    3. Paste into an e-mail and send to support@kidasa.com.
  3. Repair Project.
    1. Press the Windows Start Button.
    2. Choose Settings.
    3. Choose Apps  | Installed Apps.
    4. Locate Microsoft Project.
    5. Click the ... (3 dots) on the right and choose Repair.  (In Windows 11, first choose Modify.)  This will ensure the registry settings are correct.
    6. If you have multiple versions of Project installed, please consider removing the earlier version.  
  4. Reregister Milestones  (Maybe you have multiple versions of Milestones installed?)
    1. In Milestones, choose the Tools tab.
    2. Click the  button.
    3. Click this button: .
    4. On the dialog box, click OK and click OK again to exit the dialog box.
  5. Create an extended Log file and e-mail it to support.
    1. On the Help tab, choose 
    2. Click this button: .  It should now say ON:
    3. Click OK.
    4. Import or refresh from Microsoft Project to generate the log entries.
    5. When finished importing, go to the Tools tab and choose Reports | Schedule | Log File Viewer.
    6. Click this tab: 
    7. At the bottom of the dialog click this button: 
    8. Paste the results into an email and send to support@kidasa.com.
  6. Check for a refresh list
    1. If you are refreshing and are unable to pick a Microsoft Project file, it's possible that someone previously associated a Refresh List with the Milestones schedule in use.
    2. In Milestones, choose the Connections tab.
    3. In the Microsoft Project section, choose the  next to Refresh Previouslin Imported Project.
    4. Pick Create/Edit Refresh List.
    5. Delete all of the schedules in the list.  This will make it possible to refresh from a single file.  
    6. Be sure to remove any nicknames which might be on the Milestones schedule.  Nicknames are not used when refreshing from a single file.  To remove the nicknames:
      1. In the Microsoft Project section, choose the  next to Refresh Previouslin Imported Project.
      2. Choose Manage Nicknames in Cell and Symbol Tags.
      3. Click this button: 
  7. Check to be sure that the correct Unique ID field is being used.
    1. When refreshing a schedule, be sure to pick the same Unique ID used to build the schedule.  For example, if Text1 was used to build the schedule, use Text1 to refresh.

 

 

 

 

 

 

 

 

 

 

 

 

 

 


Related topics

Create presentation reports for Microsoft Project with Milestones

Need to change UIDs in Milestones as Project UIDs have all changed

Get list of all Project UIDs in Milestones schedule

Link a Microsoft Project schedule to my Milestones chart